ECUTalk USB Consult Cable LCD Display ECUTalk Software
Skip Navigation Links
News
ECUTalk Consult Cables
ECUTalk Consult LCD Display
V2 Firmware Updates
V2 User Guide
Feature/Bug Tracker
V1 Display Info
V1 Firmware Revisions
ECUTalk Consult Software
Screenshots
Version History
Feature/Bug Tracker
Pocket PC Compatibility
Diesel Compatibility
Contact
 

Consult LCD Firmware Revisions

V1 Firmware Revisions

To upgrade to the final 1.0 firmware version, you will need to post your display back so I can replace the chip in it. You will lose any settings you had, including time trial records, etc. There will be no further firmware upgrades past 1.0, you're encouraged to upgrade to a V2 display (trade-in V1 display for $100 discount). V2 displays have user updatable firmware via USB cable (from a laptop), see above.

v0.1 - 22/9/2006
v0.2 - 24/9/2006
v0.3 - 26/9/2006 - Added "Check Switch?" to the connection failed message as most often this will be due to switch set to consult interface (right) rather than LCD (left). Also made it so that peak values will record for values not displayed on screen (ie between screen updates).
v0.4 - 1/10/2006 - Added ability to go over 100km in time trial (useful for distance measuring on highway and future trip meter possibilities), and timer now can count over 999.999s (it goes to 99m59.9s then to 99h59m59s, not that anyone will be able to keep their car running for 100hrs continuously...)
v0.5 - 8/10/2006 - Added TPS manual range setup for percentage. Added checks for extreme values so they dont impact on peak values. Added reset when voltage falls below 4.0v on device.
v0.6 - 9/10/2006 - Initial Public Release. Fixed time trial real-time elapsed time display.
v0.7 - 27/10/2006 - Made peak Injector duty cycle values not record 100 as peak when value is over 100. So unless you hit exactly 100, it wont show 100 as peak.
v0.8 - 11/12/2006 - Injector duty cycle calculation fixed (previously displayed twice the real duty cycle).
v0.9 - 14/01/2007 - Fixed problem with detecting sensors meant display won't work on Z32 300ZX cars.
v1.0 - 29/06/2008 - Final Release. Added Trip Meter screen (accessed by pressing left/right on the main data display).

V1 Resolved Issues:



(Fixed in v0.2) - #1 - Assumes that a car with 2 x O2 also has 2 x AFM (300ZX does not). Therefore it is not displaying the 2nd O2 sensor for 300ZX.

(Fixed in v0.2) - #2 - When you have the TPS set to volts as you exit options, it will clear the max (peak) tps value. This is fixable.

(Fixed in v0.2) - #3 - Distance measure in time trial seems to be accurate at some points, but noticably overcounting on deceleration.

(Fixed in v0.3) - #4 - Second injector reading if car supports it (eg GTR) isnt shown (i didnt realise there were seperate injector banks).

(Fixed in v0.3) - #5 - Changing options doesn't clean peak value (eg if peak temp was "200F", this should be cleared so it doesnt show 200C as peak).

(Fixed in v0.4) - #6 - Distance measuring jumps to 99999.9m once you pass 9999.9m

(Fixed in v0.5) - #7 - TPS %age should be manually set up to avoid issues where spikes in TPS voltage result in it reading >0% at closed, and <100% at WOT.

(Fixed in v0.5) - #8 - Random spikes/communication errors can make peak values read very high. Eg temperature reading max (of 205C). Ignore values that are off the scale min/max values, or otherwise unobtainable.

(Fixed in v0.5) - #9 - Sometimes unit doesn't "turn on" due to volts dropping too low on starting car. Should be able to get the unit to reset itself when voltage returns to normal.

(Fixed in v0.6) - #10 - Made an error with time trial current time displaying - in versions 0.4 and 0.5 it will only show the time after time trial is completed, not as time trial is running.

(Fixed in v0.7) - #11 - Changed the peak injector duty cycle to not record values over 100 as being 100. See #12

(Fixed in v0.8) - #12 - Discovered INJ% injector duty cycle calculation resulted in a value double what it should be.

(Fixed in v0.9) - #13 - Due to 300ZX cars having 2 Injector banks but only 1 AFM, the main sensor display would not work. The time trial display still worked (as it only requires the speed). This has been fixed so it should now work on all consult cars without any issues.